Commit 8c4b5685 authored by User expired's avatar User expired
Browse files

Verion updates for various JavaScript libraries (webpack, turfjs, ...)

parent f2737470
Upcoming version:
-----------------
- Verion updates for various JavaScript libraries (webpack, turfjs, ...) (Nikolaus Krismer)
- Version upgrades for npm and selenium test drivers (Nikolaus Krismer)
- Fixed some minor js issues (Nikolaus Krismer)
- using own pouchdb caching implementation (fixes scoping issue) (Nikolaus Krismer)
......
......@@ -8,19 +8,20 @@
"url": "http://github.com/npm/npm.git"
},
"dependencies": {
"@turf/buffer": "^4.1.0",
"@turf/convex": "^4.1.0",
"@turf/inside": "^4.1.0",
"@turf/isolines": "^4.1.0",
"@turf/tin": "^4.1.0",
"@turf/buffer": "^4.5.0",
"@turf/convex": "^4.5.0",
"@turf/inside": "^4.5.0",
"@turf/isolines": "^4.5.0",
"@turf/tin": "^4.5.0",
"alpha-shape": "^1.0.0",
"concaveman": "^1.1.0",
"console": "^0.5.0",
"console": "^0.5.2",
"evispa-timo-jsclipper": "evispa/timo-jsclipper.git",
"font-awesome": "^4.7.0",
"geojson-utils": "^1.1.0",
"i18next": "^2.5.0",
"i18next-browser-languagedetector": "^0.3.0",
"grunt-cli": "^1.2.0",
"i18next": "^8.4.0",
"i18next-browser-languagedetector": "^2.0.0",
"jquery": "^3.2.0",
"jquery-i18next": "^0.2.0",
"jquery-ui": "^1.12.1",
......@@ -32,30 +33,30 @@
"leaflet.locatecontrol": "nikolauskrismer/leaflet-locatecontrol#79b7119",
"leaflet.markercluster": "^1.0.0",
"leaflet.tilelayer.pouchdbcached": "github:nikolauskrismer/Leaflet.TileLayer.PouchDBCached#da825fa",
"pako": "^1.0.0",
"pouchdb": "^6.2.0",
"pako": "^1.0.5",
"pouchdb": "6.2.0",
"reconnectingwebsocket": "^1.0.0",
"spin.js": "^2.3.0"
"spin.js": "^2.3.2"
},
"devDependencies": {
"css-loader": "^0.27.0",
"compression-webpack-plugin": "^0.4.0",
"extract-text-webpack-plugin": "^2.1.0",
"file-loader": "^0.11.0",
"compression-webpack-plugin": "^1.0.0",
"css-loader": "^0.28.4",
"extract-text-webpack-plugin": "^3.0.0",
"file-loader": "^1.0.0",
"font-awesome-webpack": "^0.0.1 || >0.0.5-beta",
"grunt": "^1.0.0",
"grunt": "^1.0.1",
"grunt-concurrent": "^2.3.0",
"grunt-contrib-compress": "^1.4.0",
"grunt-eslint": "^19.0.0",
"grunt-jsdoc": "^2.1.0",
"grunt-karma": "^2.0.0",
"grunt-text-replace": "^0.4.0",
"grunt-webpack": "^2.0.0",
"html-webpack-plugin": "^2.26.0",
"istanbul": "^0.4.0",
"istanbul-instrumenter-loader": "^1.2.0",
"json-loader": "^0.5.0",
"karma": "^1.6.0",
"grunt-webpack": "^3.0.2",
"html-webpack-plugin": "^2.29.0",
"istanbul": "^0.4.5",
"istanbul-instrumenter-loader": "^3.0.0",
"json-loader": "^0.5.6",
"karma": "^1.7.0",
"karma-coverage": "^1.1.0",
"karma-mocha": "^1.3.0",
"karma-mocha-reporter": "^2.2.0",
......@@ -66,11 +67,11 @@
"mocha": "^3.2.0",
"mocha-loader": "^1.1.0",
"node-sass": "^4.5.0",
"phantomjs-prebuilt": "^2.1.0",
"sass-loader": "^6.0.0",
"style-loader": "^0.16.0",
"phantomjs-prebuilt": "^2.1.14",
"sass-loader": "^6.0.6",
"style-loader": "^0.18.2",
"url-loader": "^0.5.0",
"webpack": "^2.3.0",
"webpack-dev-server": "^2.3.0"
"webpack": "^3.4.0",
"webpack-dev-server": "^2.6.0"
}
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment